Migrating from Java 6 (Swing) to 8

Author Topic: Migrating from Java 6 (Swing) to 8  (Read 683 times)

Offline VindieselwalkerTopic starter

  • Trade Count: (0)
  • Newbie
  • *
  • Thank You 0
  • Posts: 1
  • Karma: 0
Migrating from Java 6 (Swing) to 8
« on: 03-15-2019, 23:49:09 »
Hi

I work on a big application, which was coded almost 10 years ago.

It was coded against java 6, and we now think about upgrading to java 8.

Already tried to load everything in Eclipse and compile/launch against JDK 8 (171), almost everything works, but I still have some concerns about java stacks poping on some actions (someone told me it's related to events sequence which could have changed ?).

Also, Eclipse is warning me about restrictions on libraries (ie, sun.awt.CausedFocusEvent.Cause.ACTIVATION, but some others also, ...)

Do you have anny tips for a successfull migration to Java 8 ?

As you can imagine, I'm not an expert, so what warning should I follow ?

Thanks



 

Related Topics

  Subject / Started by Replies Last post
3 Replies
3432 Views
Last post 10-18-2012, 03:21:05
by netedge12
0 Replies
1867 Views
Last post 08-16-2011, 01:06:18
by Vinil
12 Replies
8505 Views
Last post 07-06-2016, 06:58:13
by Paavni
3 Replies
4758 Views
Last post 08-19-2015, 01:48:54
by SanviMalhotra
2 Replies
2344 Views
Last post 09-01-2015, 22:34:28
by blueangelhost