What am I doing wrong? My web went down after add new backlink

Author Topic: What am I doing wrong? My web went down after add new backlink  (Read 873 times)

Offline pablitoTopic starter

  • Trade Count: (0)
  • Semi-Newbie
  • *
  • Thank You 2
  • Posts: 10
  • Karma: 0
  • Gender: Male
    • Pozycjonowanie stron internetowych lublin
Hi,

I got some issue and i dont know what am i doing wrong. I got main web which I'm tryig to rank at seo (web A). In first place i got some links from catalogs/webs directory, presellpages than i created web (based at wordpress cms - web B) and add link to web A. Thanks to this i got 1 place at serp in this one keyword! After two months i tried to do the same thing and create another web for seo (based at wordpress cms - web C) and ad link to web A with other keyword. But instead of get better results in serp i got worse.

The domain B and domain C are domains registered on me but on different host. Do you have any idea what can be wrong?

Weekly rankings for my main keywords position in Google (at top10):
Main keyword: 7-7-7-9-8-8
Other related keyword : serp - 6-6-6-7-8-8
Other related keyword : serp - 11-11-12-10-10  (keyword that i added a link which made lower other keywords)

Post Merge: 08-06-2015, 03:03:22

Any sugestions?
« Last Edit: 08-06-2015, 03:03:22 by pablito »


 

Related Topics

  Subject / Started by Replies Last post
0 Replies
1365 Views
Last post 08-01-2015, 12:51:26
by Lauren7
2 Replies
1033 Views
Last post 11-09-2016, 21:43:09
by Mikecowell
0 Replies
437 Views
Last post 11-09-2016, 02:39:31
by RosaB
0 Replies
442 Views
Last post 12-21-2016, 19:56:46
by MartinL
4 Replies
1440 Views
Last post 05-21-2017, 23:03:29
by deekumar0203